Kubuntu 7.10 auf einem IBM Lenovo R61i

Auf meinem IBM Lenovo Notebook läuft Kubuntu 7.10 wunderbar und fast alles out-of-the box. Das Ding ist auf Intel Santa Rosa Plattform also sehr aktuell. Hier folgen die Details:

Hinweis

Auf dieser Seite findet Ihr einen persönlichen Erfahrungsbericht wie ich mein Notebook unter Linux ans Laufen gebracht habe. Dies ist keine offizielle Support-Page! Ich Übernehme keinerlei Garantie für die Angaben und es gilt der rechtliche Hinweis.

An welche Leser wende ich mich? Das Laptop läuft im wesentlichen “out-of-the-box”. Für den Rest müsst Ihr auf jeden Fall experimentierfreudig sein. Alle Einstellungen, Konfiguration, Kompliation, etc. müsst Ihr bitte selber hin bekommen. Das heißt im wesentlichen:
  1. apt bzw. den Adept Manager bedienen können
  2. Readme-Dateien lesen
  3. Die Fehlermeldungen bei ./configure bzw. make o.ä. lesen und die Problemchen lösen

Eine sehr gute Quelle für Hinweise und Fragen ist http://wiki.ubuntuusers.de/

Vorbereitungen

Leider ist das Laptop nicht sinnvoll ohne Windows Steuer zu kaufen. Lenovo verzichtet auf Installationsmedien und sogar auf Recovery CDs. Via “ThinkVantage”-Taste lässt sich ein Recovery Mode booten, der auf einer 5 GB Partition lebt. Da ich auf Windows komplett verzichten kann, habe ich die MS EULA nicht angeklickt, aber zur Vorsicht eine Sicherung gefahren.

Das geht wie folgt: Von der Kubuntu Live CD booten, eine USB-Festplatte anschließen, eine Shell aufmachen z.B. Alt+F2 “Konsole” und nun per dd sichern. Etwa so:

sudo dd if=/dev/sda | gzip --fast -c | split -d -b 650m  - /media/disk/r61i/sda_image.gz.

zurück spielen geht dann (hoffentlich) so:

sudo cat  /media/disk/r61i/sda_image.gz.* | gunzip -c | sudo dd of=/dev/sda

Macht das bitte wirklich auf eigene Gefahr! Lerne vorher etwas über dd (Google ist Dein Freund). Übrigens dauert der ganze Vorgang über eine Stunde, das sind ja auch 160 GB die low-level abgeklappert werden müssen. Am Ende kamen bei mir ca. 30 GB Dateien an.

Installation von Kubuntu 7.10 (Gutsy Gibbon)

Die Installation von Gutsy läuft einwandfrei durch. Da mein Notebook eine Core 2 Duo T5250 1.5 GHz CPU hat, musste ich die 64bit (amd64) Version von Kubuntu nehmen (siehe http://wiki.ubuntuusers.de/Downloads)

++ Grafikkarte — Intel GMA X3100

Funktioniert auf Anhieb mit der richtigen Auflösung und 3D Unterstützung.

Anmerkung: Seit Kubuntu 10.04 werden Browser Flash-Videos im Vollbild nicht angezeigt. Man hört den Ton, aber das Videobild bleibt dunkel. Die Lösung ist die Einstellung “OverrideGPUValidation=true” in einer Datei Namens /etc/adobe/mms.cfg . Das geht etwa so:

echo "OverrideGPUValidation=true" > /tmp/mms.cfg
sudo mkdir /etc/adobe
sudo mv /tmp/mms.cfg /etc/adobe

+ Powermanagement – ACPI

Batterieanzeige funktioniert, Bildschirm abschalten und automatisches abschalten bei leerem Akku. Auch die per ACPI angesteuerten Tasten, siehe Tastatur.

++ Ruhezustand (suspend to ram)

Funktioniert einwandfrei, keine Ahnung ob wirklich jedes Device wieder läuft, aber USB, Netzwerk, etc. geht.

++ Tiefschlaf (suspend to disk, hibernate)

Funktioniert einwandfrei, siehe oben. Allerdings ist suspend to disk bei 3 GB Hauptspeicher fast genauso schnell, wie neu booten :-)

++ Synaptics Touchpad und Mausersatz

Sowie externe Mäuse, alles funktioniert

++ USB

Funktioniert.

++ Tastatur

Funktioniert ziemlich vollständig, Laut, Leise, Stumm, suspend to ram, zoom, sogar die Mediensteuerung. Die Hell-Dunkel-Steuerung funktioniert mit Kubuntu 10.10 (eventuell auch älteren Versionen).

++ Netzwerk – Intel PRO/Wireless 3945ABG WLAN

Beide Netzwerkkarten laufen out-of-the-box.

++ Audio

Funktioniert. Nach der Installation war der Kanal PCM auf Lautstärke 0 eingestellt, man hörte nichts. Nach dem Einsatz von kmix war auch dieses Problemchen beseitigt.

+ SD/MMC cardreader

Meldet sich als Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter und funktioniert einwandfrei.

++ Bluetooth

Funktioniert einwandfrei.

? Modem

Nicht ausprobiert, dieses SoftModem kann man mit einiger Wahrscheinlichkeit zum funktionieren bringen (siehe ThinkWiki)

? Fingerprint-Leser

Nicht ausprobiert, kann ggf. ans Laufen gebracht werden, siehe den Hinweis im ThinkWiki.

? PCMCIA

Scheint zu laufen. Noch nicht ausprobiert.

Anregungen?

Verbesserungsvorschläge, Lösungen, etc. bitte als Kommentar (siehe unten).

Links

www.ibm.com — Hardware Maintenance Manual — ThinkPad R61, R61e, R61i
Sehr gute Einstiegspunkte für Linux auf Notebooks/Laptops sind:

http://tuxmobil.de/

http://www.linux-on-laptops.com/

12 Gedanken zu „Kubuntu 7.10 auf einem IBM Lenovo R61i

  1. Andi

    Hi Werner,

    du schreibst dass die Lautstärke-Tasten ohne Probleme funktionieren. Musstest du dazu irgendwas machen? Wenn ich die Tasten drücke springt der Regler immer nur zwischen 0 und 11%. Stummschaltung funktioniert auch nicht :(

    Hoffe du hast da einen Tipp,
    danke
    Andi

  2. Werner Roth Artikelautor

    Hallo Andi,

    bei mir funktionieren die Tasten Mute, Laut und Leise einwandfrei von 0% bis 100%. Genauso auch auf meiner externen Tastatur. Mit dem einzigen Unterschied, dass bei Mute auf der Laptop-Tastatur neben dem OSD-Lautstärke-Balken noch ein zusätzlicher blauer Balken eingeblendet wird.

    Hast Du mal in Kmix bzw. alsamixer geschaut, ob alle Kanäle aufgedreht sind?

    Grüße
    Werner

  3. Andi

    Ein Mail-Notify für dein Blog wäre was ;)
    Was meinst du genau mit “aufgedreht”? Der Ton am Notebook tut soweit und ich kann ihn auch regeln wenn ich direkt über den Lautsprecher im Systray gehe, aber die Tasten des Notebooks funktionieren halt nicht. Hab diese Fehlerbeschreibung auch schon mehrfach gelesen, aber keine Behebung.
    Daher dachte ich dass du da evtl irgendwo einen Haken gesetzt hast oder so…

    Pfeift dein Display auch, wenns auf Akku läuft?

    Wobei mir grad auffällt, dass ich das R61 hab und nicht das R61i. Keine Ahnung ob das nen großen Unterschied macht.
    Andi

  4. Werner Roth Artikelautor

    Hallo Andi,

    Ich war über die 11% gestolpert. Nein, ich habe außer “Vollduplex” (für WengoPhone) und Mixer nichts am Soundsystem verstellt.

    Mein Display pfeift nicht. Meine Kritikpunkte sind: Die Lüfter laufen ständig bei einer CPU Temperatur von 35

  5. Andi

    Hi,

    sehr komisch, dass das mit dem Ton bei dir einfach so funktioniert. Ich werd mich dann mal weiter durch tuxmobil wühlen. Vielleicht find ich ja in einer der Aufstellungen einen Hinweis.
    Das mit dem Lüfter hab ich auch. DVD fand ich ganz ok soweit.

    Subscribe to Comments ist soweit ich weiss bei WordPress dabei. Zumindest wars das bei mir ;)

    bye
    Andi

  6. Andi

    Nachtrag meinerseits. Ich hab mal Ubuntu drauf geworfen, darin funktioniert einiges out-of-the-box besser, auch die Lautstärkeregelung. Wenn man dann zurück nach KDE wechselt funktioniert die Lautstärke Regelung plötzlich… KDE mag ich aber lieber, auch wenns schon nett ist, wie Ubuntu so daher kommt …

  7. Michi

    Nmorgen,

    ich habe hier das selbe Problem mit meinem R61. Sobald ich die Thinkpad-Lautstärke Tasten verwende springe ich nur zwischen 0% und 11%. Hat jemand eine Lösung hierfür gefunden? Habe übrigens Kubuntu 7.10

  8. Sascha

    moin moin,

    ich hab noch was bezüglich Windows, akzeptiert die lizenzbedingungen nicht und schreibt an Lenovo dort könnt ihr dann die Rückerstattung der ungenutzten Lizenz fordern! (weiteres über Google)

    –Sascha

  9. Marc

    Hallo,

    irgendwie bekomme ich das WLan nich zum laufen unter Kubuntu 7.10

    Hatte jemand damit Probs?

    -Marc-

  10. Michael

    Hi,
    ich spiele mit dem Gedanken 20 Stück davon für unsere Hochschule zu kaufen.
    Wie sieht es denn mit der Akkulaufzeit aus?
    Und wie gut sind die Scharniere noch? Halten die noch gut?
    Wie ist es mit der Tastatur? Klappert die schon?
    Hat jemand mal die Übertragungsraten der WLAN-Karte im 802.11n-Modus probiert?

  11. Werner Roth Artikelautor

    - Akkulaufzeit, keine Ahnung betreibe das Ding fast ausschließlich am Netz. Nach zwei Stunden zeigt das KDE-Tool 50% an, ich schätze also eher im okayen als im tollen Bereich.
    - Scharniere, Tastatur, etc. alles super. Ein Benutzer aus Polen schreib er hätte ein solches Notebook bei einer Elektrokette ausprobiert und alles wäre Mist. Kann ich nicht bestätigen, ich hoffe es gibt keine zwei Qualitäten.
    - Mein WLAN-Router ist zu alt, mit 802.11n kann ich nicht dienen.

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Du kannst folgende HTML-Tags benutzen: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>