Kubuntu 11.04 Gimp startet nicht

Ein wie ich finde erstaunlicher Fehler für eine Distribution: Unter Kubuntu 11.04 Natty Narwhal startet Gimp nicht. Es schmeißt beim Starten folgende Fehlermeldung:

(gimp:<id>): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132:
ignoring no-arg, optional-arg or filename flags (8) on option of type 0                                                                                                                      
Speicherzugriffsfehler

Per Google findet sich „change GTK+appearance to Raleigh and back to Oxygen“. Schön also hier ist der Workaround bzw. die Lösung in Detail und Deutsch wie folgt:

  1. KDE->Systemeinstellungen
  2. Erscheinungsbild von Anwendungen
  3. GTK+-Erscheinungsbild
  4. Widget Stil umschalten auf „Raleigh“, Schaltfläche „Anwenden“, Fenster ruhig offen lassen.
  5. Gimp starten (ruhig wieder beenden)
  6. Widget Stil umschalten auf „oxygen-gtk“, Schaltfläche „Anwenden“
  7. Fertig, ab jetzt startet Gimp auch ohne obige Prozedur.

Das irgendeine selten genutzte Anwendung Probleme macht, okay. Gimp ist glaube ich unter den Top 5 der Computernutzer. Jungs macht daraus einen Prio-Bug.

Nachtrag: Es genügt anscheinend das Verzeichnis „.gimp-2.6“ anzulegen. Also konsole auf und

mkdir ~/.gimp-2.6

Jetzt sollte Gimp ohne Fehler starten.

https://bugs.launchpad.net/ubuntu/+source/gimp/+bug/742516

27 Gedanken zu „Kubuntu 11.04 Gimp startet nicht

  1. George Ruinelli

    Vielen Dank für den Tipp!

    Erwähnen sollte man noch, dass man das Erscheinungsbild nur einmal so umstellen muss. Danach scheint Gimp „gefixt“ zu sein.

  2. cheoops

    Ich wollte nur einmal ein Danke für die Lösung da lassen! Hab mich schon gewundert warum es nicht startet!

  3. Ubuntianer

    Hey, Mensch, danke!
    Ich bin wegen Unity zu Kubuntu gewechselt und hab mich schon gewundert, weshalb Gimp nicht startet.

    Beste Grüße

  4. Ubuntianer

    Ahh…

    Vielleicht kannst du mir in einem Punk weiterhelfen?!

    Thunderbird übergibt nicht die Links von E-Mails an den Firefox.

    Hast du eine Idee, weshalb?

    Beste Grüße

  5. Volker

    Bei mir ist das Problem des Nicht-Startens erst nach einigen Tagen aufgetreten (und sicherlich nach einigen Updates). Ich hatte schon vermutet, eine Neuinstallation machen zu müssen. Auf jeden Fall hatte mich deine Fehlerbeschreibung gerettet! Danke schön dafür. Wenn es mal ein Bugfix gibt wäre ich sehr dankbar über eine Info!!

    Täusche ich mich oder hatte der „Narwal“ das Schwimmen noch nicht so ganz gelernt hat??

    Volker

  6. Werner Roth Artikelautor

    Hallo Volker,

    bis auf das Gimp-Problem bin ich mit mit 11.04 ganz zufrieden. Ich habe hier das Heim-Netzwerk sehr schnell umgestellt, da der Nvidia-Treiber mir bei 10.10 ruckartig 30% bis 40% CPU-Last einbrockte. War nie schlimm, aber auf dieses W*-Feeling hatte ich unter Linux keine Lust. Der mit 11.04 gelieferte nouveau inkl. experimentellem 3D ist anscheinend sehr Okay (nVidia GeForce 8400GS).

    Das Netbook mit Touchscreen läuft nun Out-of-the-Box. Der dritte PC war nach zig. Distribution Updates fällig, da lief irgendwie HAL noch nebenher, lahm, seltsame Hänger. Plattmachen: Home-Verzeichnis ge-TAR-ed, Applikationsliste gezogen, CD rein, Home-Verzeichnis zurück gespielt, apt-get die Applikationsliste gegeben, noch zwei Leichen nachgezogen. Gesamter Umzug inkl. allem 2 h. Ich liebe es wenn die Dinge schön designed sind 🙂

    Viele Grüße
    Werner

  7. Volker

    Hallo Werner,

    vermutlich bin ich an einem großen Teil meiner Probleme selbst schuld – richtig. Und es stimmt auch, daß die 11.04-Kubuntu-Version nicht wirklich schlecht ist. Ich denke halt nur, daß man mit diesem System und KDE-Version vieles (möglicherweise kurzfristig) verschlimmbessert hat.

    Ich betreibe diese Version weitgehend auf einem Sony-Netbook was vollständig mit einem Intel-Chipset ausgerüstet ist. Die Grafikkarte N10/GMA3150 von Intel ließ sich nur mit Script per xrendr zu einem zweiten Monitor überreden. Aus dem Stand erkannte es auch nur die falsche Auflösung.

    Die Energieverwaltung finde ich auch nicht sonderlich geglückt – die Betätigung den „Power-Buttons“ heißt bei mir „Sofort Runterfahren“, und nicht erst in einer Minute (da weiß ich bis heute noch nicht, wie ich das abstelle).

    Naja – und dann noch, wenn man es dringend braucht, ein Ausfall von GIMP. Da kann schon Frust aufkommen.

    Aber insgesamt ist diese Kubuntu-Version sicher nicht die schlechteste. Ich glaube aber, die 10.4 (LTS) war die ältere, aber die bessere. Da ist die Sicht auf die Dinge aber sicher sehr subjektiv.

    Beste Grüße und Danke schön!
    Volker

  8. Pingback: Habe mir Kubuntu 11.04 installiert… « RedEagle's Blog

  9. Patrik

    Danke für den Tip. Das mit dem Verzeichnis löst es sofort.

    Ich finde für freie kostenlose Software ist Kubuntu einfach der Hammer. Kleine Fehler gibts bei Windows auch genug, aber mit fetter Rechnung. Ganz zu schweigen von diverser teurer Spezialsoftware…

  10. Thomas

    Nur falls jemand (wie ich) mit einem allgemeineren GTK+ Problem reinschaut:

    sudo apt-get install qtcurve

    Dann GTK-Erscheinung auf QtCurve umstellen; das wirkt z.B. Geany Wunder. 🙂

  11. Matthias

    das Verzeichnis anlegen, wie im Nachtrag beschrieben, reicht tatsächlich, hab’s grad gemacht und Gimp ist da, vielen Dank !!

  12. Andrew

    Hello…

    Bei mir als Laien hört es leider schon da auf, dass meine System settings auf English sind und es kein Raleigh gibt…

    Ausserdem wo und was ist die Konsole?

    Ich bin verzweifelt…

    Grüsse A.

  13. Werner Roth Artikelautor

    Hallo,

    KDE->Anwendungen->System->Terminal
    oder einfach im Dolphin (Dateimanager) rechte Maustaste, neuer Ordner „.gimp-2.6“ (den Punkt nicht vergessen).

    Grüße
    Werner

  14. Andrew

    Hallo Werner…

    Vielen Dank für Deine Antwort…

    Jedoch…

    der inhaltslose ordner wurde zwar angelegt…hat jedoch nix gebracht…

    unter Anwendung im system komme ich auf einen gnome terminal emulator…jedoch lassen sich keine Befehle einfügen…oder gar ausführen…ahhh…

    gut…da gab es benutzerdefiniert…da habe ich es reinkopiert…

    aber ausführen geht auch nicht…

    und Gimp läuft immer noch nicht…

    es ist echt zum weinen…

  15. Andrew

    Hallo Werner,

    Sorry, dass ich mich so spät melde, doch war ich im Urlaub…

    Vielen Dank für Deinen Tipp…mir unerklärlich, jedoch als ich einen Tag später nochmal neu startete(es war das Dritte mal seit ich deine Schritte befolgt hatte…

    Und siehe da…es funktioniert!!! Nochmals 1.000 Dank!!!

    Aber ich hätte noch eine andere Frage…

    In meinem Tonstudio habe ich einen MAC auf den habe ich GIMP installiert…(kann zwar nicht abspeichern aber das ist eine andere Story…hehe) dort werden von Gimp RAW Dateien geöffnet und können sofort bearbeitet werden …

    Unter Linux funktioniert das nicht…(UF-RAW ist mir bekannt…nur den Zwischenschritt finde ich doof…)

    Beste Grüsse…

    A.

  16. Pingback: Gimp und Kubuntu | aufgebauscht

  17. Pingback: GIMP startet nicht unter Kubuntu 11.04 – Christoph Janser

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *